Mobile Access Management

Incident Report for Imprivata

Postmortem

During scheduled database maintenance, a lock-intensive database change encountered normal production traffic and created a large queue of waiting requests. This caused database connections and resource usage to rise rapidly, resulting in intermittent application unavailability and disconnections for some connected clients. The initial database change was reverted, which produced partial recovery, but the service later became unstable again as queued and reconnecting workload returned. A database restart provided the clean recovery point that restored stable service.

Posted Sep 09, 2026 - 10:47 EDT

Resolved

Restoration of normal MAM functionality has been confirmed at 0500EDT. Imprivata will deliver a root cause analysis here in due course.
Posted Sep 08, 2026 - 05:46 EDT

Monitoring

Full functionality has been restored in MAM and Imprivata continues to closely monitor systems to assure stability. If customers still encounter errors with Check In and Check Out please retry. If that fails please contact Customer Support.
Posted Sep 08, 2026 - 05:24 EDT

Investigating

Imprivata is aware of an issue with Mobile Access Management (MAM) following the earlier maintenance. This is affecting the US Shared Cluster (C1), and may be seen as an error on Launchpads not able to acknowledge a deployment request. We are urgently investigating this and a further update will follow.
Posted Sep 08, 2026 - 04:17 EDT
This incident affected: Mobile Access Management (US Cloud Services).