Nexus issues post 3.10.1 upgrade
Incident Report for Imprivata
Postmortem

Affected versions:

  • Nexus 3.10.1
  • VPAM/CPAM < 24.1.9

Setup to trigger the issue:

From a CPAM server with version lower than 24.1.9, connect to a VPAM/CPAM server with version equal or greater than 24.1.9 using Nexus version 3.10.1. Once the connection is establish the CPAM server will terminate all active Nexus sessions and restart the Nexus connection. Note, this issue will not happened if the CPAM server acting as Vendor server in the Nexus relationship is a version equal or greater than 24.1.9.

Root Cause:

As part of adding support for status updates of port/services in active sessions, we added a new command associated with the Nexus protocol version 119. The changes required to support this new command were implemented in version 24.1.9 of the CPAM/VPAM server, and in version 3.10.1 of Nexus. With the Nexus update, the feature was enabled for all CPAM/VPAM servers with version greater or equal than 24.1.9. However, due to an incorrect check of the version of the CPAM/VPAM server in the Nexus side, the new command used to communicate port status updates was sent to servers that do not support the feature. Specifically, the message was sent to the Vendor servers in the Nexus relationship, which caused the server to restart the Nexus connection, terminate all active sessions to Nexus sites and leaving the server unable to start new sessions while the reconnect/resync process with Nexus was executed.

Posted Nov 25, 2024 - 10:16 EST

Resolved
This incident has been resolved as of the roll back done earlier today. If you continue having issues, please reach out to Customer Support.
Posted Nov 19, 2024 - 14:10 EST
Update
Nexus has been rolled back to 3.7.0 while we investigate the issue. Services should be functional at this point. Please reach out to support if you continue experiencing issues.
Posted Nov 19, 2024 - 11:25 EST
Update
We are currently investigating the issue. A nexus rollback is planned to happen at 10:15 (CT) to alleviate the issue for affected customers.
Posted Nov 19, 2024 - 10:56 EST
Investigating
We are currently investigating this issue.
Posted Nov 19, 2024 - 10:54 EST
This incident affected: Imprivata PAM (Nexus).